FamilyItemFactoryNewFormByCap Method |
Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Form NewFormByCap(
bool isSolid,
ReferenceArray profile
)
Public Function NewFormByCap (
isSolid As Boolean,
profile As ReferenceArray
) As Form
public:
Form^ NewFormByCap(
bool isSolid,
ReferenceArray^ profile
)
member NewFormByCap :
isSolid : bool *
profile : ReferenceArray -> Form
Parameters
- isSolid Boolean
- Indicates if the Form is Solid or Void.
- profile ReferenceArray
- The profile of the newly created cap. It should consist of only one curve loop.
Return Value
FormIf creation was successful new form is returned.
See Also