ItemFactoryBaseNewDimension(View, Line, ReferenceArray, DimensionType) Method |
Creates a new linear dimension object using the specified dimension style.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewDimension(
View view,
Line line,
ReferenceArray references,
DimensionType dimensionType
)
Public Function NewDimension (
view As View,
line As Line,
references As ReferenceArray,
dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewDimension(
View^ view,
Line^ line,
ReferenceArray^ references,
DimensionType^ dimensionType
)
member NewDimension :
view : View *
line : Line *
references : ReferenceArray *
dimensionType : DimensionType -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
The view must be if the document is in [!:Autodesk::Revit::DB::SketchEditScope].
- line Line
- The line drawn for the dimension.
- references ReferenceArray
- An array of geometric references to which the dimension is to be bound.
- dimensionType DimensionType
- The dimension style to be used for the dimension.
Return Value
Dimension If successful a new dimension object, otherwise
.
ExceptionsException | Condition |
---|
ArgumentException | Thrown when references are not geometric references. |
See Also