FamilyItemFactoryNewAngularDimension(View, Arc, Reference, Reference) Method |
Creates a new angular dimension object using the default dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewAngularDimension(
View view,
Arc arc,
Reference firstRef,
Reference secondRef
)
Public Function NewAngularDimension (
view As View,
arc As Arc,
firstRef As Reference,
secondRef As Reference
) As Dimension
public:
Dimension^ NewAngularDimension(
View^ view,
Arc^ arc,
Reference^ firstRef,
Reference^ secondRef
)
member NewAngularDimension :
view : View *
arc : Arc *
firstRef : Reference *
secondRef : Reference -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
- arc Arc
- The extension arc of the dimension.
- firstRef Reference
- The first geometric reference to which the dimension is to be bound.
The reference must be perpendicular to the extension arc.
- secondRef Reference
- The second geometric reference to which the dimension is to be bound.
The reference must be perpendicular to the extension arc.
Return Value
DimensionIf creation was successful the new angular dimension is returned,
otherwise an exception with failure information will be thrown.
Exceptions
Remarks The currently user set default style is used for the created dimension.
See Also