ItemFactoryBaseNewReferencePlane2 Method |
Creates a new instance of ReferencePlane.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ReferencePlane NewReferencePlane2(
XYZ bubbleEnd,
XYZ freeEnd,
XYZ thirdPnt,
View pView
)
Public Function NewReferencePlane2 (
bubbleEnd As XYZ,
freeEnd As XYZ,
thirdPnt As XYZ,
pView As View
) As ReferencePlane
public:
ReferencePlane^ NewReferencePlane2(
XYZ^ bubbleEnd,
XYZ^ freeEnd,
XYZ^ thirdPnt,
View^ pView
)
member NewReferencePlane2 :
bubbleEnd : XYZ *
freeEnd : XYZ *
thirdPnt : XYZ *
pView : View -> ReferencePlane
Parameters
- bubbleEnd XYZ
- The bubble end applied to reference plane.
- freeEnd XYZ
- The free end applied to reference plane.
- thirdPnt XYZ
- A third point needed to define the reference plane.
- pView View
- The specific view apply to the Reference plane.
Return Value
ReferencePlane The newly created reference plane.
Remarks
Example
XYZ bubbleEnd = new XYZ(1, 0, 0);
XYZ freeEnd = new XYZ(-5, 0, 0);
XYZ thirdPnt = new XYZ(0, 15, 0);
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
Dim bubbleEnd As New XYZ(1, 0, 0)
Dim freeEnd As New XYZ(-5, 0, 0)
Dim thirdPnt As New XYZ(0, 15, 0)
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also