Item |
public FamilyInstance NewFamilyInstance( Face face, Line position, FamilySymbol symbol )
Exception | Condition |
---|---|
ArgumentNullException | Thrown when a non-optional argument was null. |
ArgumentException | Thrown when the function cannot get the Reference from the face, or, Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased |
ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face. |
InvalidOperationException | Thrown when Revit is unable to place the family instance. |
ArgumentException | Thrown if The symbol is not active. |
The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.
The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.
Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.
public void PlaceStiffenerOnWallFace(Autodesk.Revit.DB.Document doc, Wall wall) { // The structural stiffeners family type is compatible with line-based face placement FilteredElementCollector fsCollector = new FilteredElementCollector(doc); fsCollector.OfClass(typeof(FamilySymbol)).OfCategory(BuiltInCategory.OST_StructuralStiffener); FamilySymbol stiffenerSymbol = fsCollector.FirstElement() as FamilySymbol; // The only way to get a Face to use with this NewFamilyInstance overload // is from Element.Geometry with ComputeReferences turned on Face face = null; Options geomOptions = new Options(); geomOptions.ComputeReferences = true; GeometryElement wallGeom = wall.get_Geometry(geomOptions); foreach (GeometryObject geomObj in wallGeom) { Solid geomSolid = geomObj as Solid; if (null != geomSolid) { foreach (Face geomFace in geomSolid.Faces) { face = geomFace; break; } break; } } // Generate line for path BoundingBoxUV bbox = face.GetBoundingBox(); UV lowerLeft = bbox.Min; UV upperRight = bbox.Max; double deltaU = upperRight.U - lowerLeft.U; double deltaV = upperRight.V - lowerLeft.V; double vOffset = deltaV * 0.80; // 80% up the wall face UV firstPoint = lowerLeft + new UV(deltaU * 0.30, vOffset); UV lastPoint = lowerLeft + new UV(deltaU * 0.70, vOffset); Line line = Line.CreateBound(face.Evaluate(firstPoint), face.Evaluate(lastPoint)); doc.Create.NewFamilyInstance(face, line, stiffenerSymbol); }