FamilyItemFactoryNewLinearDimension(View, Line, ReferenceArray, DimensionType) Method |
Creates a new linear dimension object using the specified dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewLinearDimension(
View view,
Line line,
ReferenceArray references,
DimensionType dimensionType
)
Public Function NewLinearDimension (
view As View,
line As Line,
references As ReferenceArray,
dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewLinearDimension(
View^ view,
Line^ line,
ReferenceArray^ references,
DimensionType^ dimensionType
)
member NewLinearDimension :
view : View *
line : Line *
references : ReferenceArray *
dimensionType : DimensionType -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
- line Line
- The extension line of the dimension.
- references ReferenceArray
- An array of geometric references to which the dimension is to be bound.
You must supply at least two references, and all references supplied must be parallel to each other
and perpendicular to the extension line.
- dimensionType DimensionType
- The dimension style to be used for the dimension.
Return Value
DimensionIf creation was successful the new linear dimension is returned,
otherwise an exception with failure information will be thrown.
Exceptions
See Also