ItemFactoryBase Class

The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.CreationItemFactoryBase
      Autodesk.Revit.CreationDocument
      Autodesk.Revit.CreationFamilyItemFactory

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ItemFactoryBase : APIObject

The ItemFactoryBase type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodNewAlignmentAdd a new locked alignment into the Autodesk Revit document.
Public methodNewDetailCurve Creates a new detail curve element.
Public methodNewDetailCurveArray Creates an array of new detail curve elements.
Public methodCode exampleNewDimension(View, Line, ReferenceArray) Creates a new linear dimension object using the default dimension style.
Public methodNewDimension(View, Line, ReferenceArray, DimensionType) Creates a new linear dimension object using the specified dimension style.
Public methodCode exampleNewFamilyInstance(Face, Line, FamilySymbol)Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public methodCode exampleNewFamilyInstance(Line, FamilySymbol, View)Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public methodCode exampleNewFamilyInstance(Reference, Line, FamilySymbol)Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public methodNewFamilyInstance(XYZ, FamilySymbol, StructuralType)Inserts a new instance of a family into the document, using a location and a type/symbol.
Public methodNewFamilyInstance(XYZ, FamilySymbol, View)Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public methodCode exampleNewFamilyInstance(Face, XYZ, XYZ, FamilySymbol)Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public methodCode exampleNewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol)Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public methodCode exampleNewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType)Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public methodNewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType)Inserts a new instance of a family into the document, using a location, type/symbol, and the level.
Public methodCode exampleNewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType)Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public methodCode exampleNewFamilyInstances2 Creates Family instances within the document.
Public methodCode exampleNewGroupCreates a new type of group.
Public methodCode exampleNewModelCurve Creates a new model line element.
Public methodNewModelCurveArray Creates an array of new model line elements.
Public methodCode exampleNewReferencePlane Creates a new instance of ReferencePlane.
Public methodCode exampleNewReferencePlane2 Creates a new instance of ReferencePlane.
Public methodPlaceGroupPlace an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Top
Remarks
The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. This class holds common methods used in both project documents and family documents.
See Also