ItemFactoryBaseNewReferencePlane Method |
Creates a new instance of ReferencePlane.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ReferencePlane NewReferencePlane(
XYZ bubbleEnd,
XYZ freeEnd,
XYZ cutVec,
View pView
)
Public Function NewReferencePlane (
bubbleEnd As XYZ,
freeEnd As XYZ,
cutVec As XYZ,
pView As View
) As ReferencePlane
public:
ReferencePlane^ NewReferencePlane(
XYZ^ bubbleEnd,
XYZ^ freeEnd,
XYZ^ cutVec,
View^ pView
)
member NewReferencePlane :
bubbleEnd : XYZ *
freeEnd : XYZ *
cutVec : XYZ *
pView : View -> ReferencePlane
Parameters
- bubbleEnd XYZ
- The bubble end applied to reference plane.
- freeEnd XYZ
- The free end applied to reference plane.
- cutVec XYZ
- The cut vector apply to reference plane, should perpendicular
to the vector (bubbleEnd-freeEnd).
- pView View
- The specific view apply to the Reference plane.
Return Value
ReferencePlane The newly created reference plane.
Remarks
Example
XYZ bubbleEnd = new XYZ(1, 0, 0);
XYZ freeEnd = new XYZ(-5, 0, 0);
XYZ cutVec = new XYZ(0, 0, 1);
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
Dim bubbleEnd As New XYZ(1, 0, 0)
Dim freeEnd As New XYZ(-5, 0, 0)
Dim cutVec As New XYZ(0, 0, 1)
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also