FamilyItemFactoryNewFormByThickenSingleSurface Method |
Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Form NewFormByThickenSingleSurface(
bool isSolid,
Form singleSurfaceForm,
XYZ thickenDir
)
Public Function NewFormByThickenSingleSurface (
isSolid As Boolean,
singleSurfaceForm As Form,
thickenDir As XYZ
) As Form
public:
Form^ NewFormByThickenSingleSurface(
bool isSolid,
Form^ singleSurfaceForm,
XYZ^ thickenDir
)
member NewFormByThickenSingleSurface :
isSolid : bool *
singleSurfaceForm : Form *
thickenDir : XYZ -> Form
Parameters
- isSolid Boolean
- Indicates if the Form is Solid or Void.
- singleSurfaceForm Form
- The single-surface form element. It can have one top/bottom face or one side face.
- thickenDir XYZ
- The offset of capped solid.
Return Value
FormThis function will modify the input singleSurfaceForm and return the same element.
See Also