FamilyItemFactoryNewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) Method

Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Sweep NewSweep(
	bool isSolid,
	ReferenceArray path,
	SweepProfile profile,
	int profileLocationCurveIndex,
	ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid  Boolean
Indicates if the Sweep is Solid or Void.
path  ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile  SweepProfile
The profile to create the new Sweep. The profile must lie in the XY plane, and it will be transformed to the profile plane automatically. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex  Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation  ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

Sweep
If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.
Exceptions
ExceptionCondition
ArgumentException Thrown when the input argument-path-is or empty or an unsupported curve type.
ArgumentNullException Thrown when the input argument-profile-is .
ArgumentOutOfRangeException Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
ArgumentOutOfRangeException Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
InvalidOperationException Thrown when the creation failed.
Remarks
This method creates a sweep in a family document. The sweep will trace the profile along the path.
See Also