ItemFactoryBaseNewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) Method

Inserts a new instance of a family into the document, using a location, type/symbol, and the level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstance NewFamilyInstance(
	XYZ location,
	FamilySymbol symbol,
	Level level,
	StructuralType structuralType
)

Parameters

location  XYZ
The physical location where the instance is to be placed.
symbol  FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level  Level
The level onto which the FamilyInstance is to be placed.
structuralType  StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
If creation was successful then an instance to the new object is returned, otherwise .
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the family symbol does not exist in the given document.
ArgumentExceptionThrown if the level does not exist in the given document.
ArgumentExceptionThrown if The symbol is not active.
Remarks
This method is used to place a family instance onto a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

See Also