FamilyItemFactoryNewRadialDimension(View, Reference, XYZ) Method |
Creates a new radial dimension object using the default dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewRadialDimension(
View view,
Reference arcRef,
XYZ origin
)
Public Function NewRadialDimension (
view As View,
arcRef As Reference,
origin As XYZ
) As Dimension
public:
Dimension^ NewRadialDimension(
View^ view,
Reference^ arcRef,
XYZ^ origin
)
member NewRadialDimension :
view : View *
arcRef : Reference *
origin : XYZ -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
- arcRef Reference
- Geometric reference of the arc to which the dimension is to be bound.
- origin XYZ
- The point where the witness line of the radial dimension will lie.
Return Value
DimensionIf creation was successful the new arc length dimension is returned,
otherwise an exception with failure information will be thrown.
Exceptions
Remarks The currently user set default style is used for the created dimension.
See Also