ItemFactoryBaseNewDetailCurve Method |
Creates a new detail curve element.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DetailCurve NewDetailCurve(
View view,
Curve geometryCurve
)
Public Function NewDetailCurve (
view As View,
geometryCurve As Curve
) As DetailCurve
public:
DetailCurve^ NewDetailCurve(
View^ view,
Curve^ geometryCurve
)
member NewDetailCurve :
view : View *
geometryCurve : Curve -> DetailCurve
Parameters
- view View
- The view in which the detail curve is to be visible.
- geometryCurve Curve
- The internal geometry curve for detail curve. It should be a bound curve.
Return Value
DetailCurve If successful a new detail curve element. Otherwise
.
Exceptions
Remarks Different type of detail curve element will be returned according to the type of geometry curve.
See Also