FamilyItemFactoryNewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) Method |
Creates a new arc length dimension object using the specified dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewArcLengthDimension(
View view,
Arc arc,
Reference arcRef,
Reference firstRef,
Reference secondRef,
DimensionType dimensionType
)
Public Function NewArcLengthDimension (
view As View,
arc As Arc,
arcRef As Reference,
firstRef As Reference,
secondRef As Reference,
dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewArcLengthDimension(
View^ view,
Arc^ arc,
Reference^ arcRef,
Reference^ firstRef,
Reference^ secondRef,
DimensionType^ dimensionType
)
member NewArcLengthDimension :
view : View *
arc : Arc *
arcRef : Reference *
firstRef : Reference *
secondRef : Reference *
dimensionType : DimensionType -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
- arc Arc
- The extension arc of the dimension.
- arcRef Reference
- Geometric reference of the arc to which the dimension is to be bound.
This reference must be parallel to the extension arc.
- firstRef Reference
- The first geometric reference to which the dimension is to be bound.
This reference must intersect the arcRef reference.
- secondRef Reference
- The second geometric reference to which the dimension is to be bound.
This reference must intersect the arcRef reference.
- dimensionType DimensionType
- The dimension style to be used for the dimension.
Return Value
DimensionIf creation was successful the new arc length dimension is returned,
otherwise an exception with failure information will be thrown.
Exceptions
See Also