Autodesk.Revit.Creation Namespace

 
Classes
 ClassDescription
Public classApplication The Application Creation object is used to create new instances of utility objects.
Public classAreaCreationData A class which wraps the arguments of Area for batch creation
Public classDocumentThe Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Public classFamilyInstanceCreationDataA class which wraps the arguments of FamilyInstance for batch creation.
Public classFamilyItemFactoryThe Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Public classItemFactoryBaseThe ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Enumerations
 EnumerationDescription
Public enumerationeRefFaceIndicates the reference face. The Opening will be created at the direction perpendicular to the reference face.