FamilyItemFactoryNewRadialDimension(View, Reference, XYZ, DimensionType) Method |
Generate a new radial dimension object using a specified dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewRadialDimension(
View view,
Reference arcRef,
XYZ origin,
DimensionType dimensionType
)
Public Function NewRadialDimension (
view As View,
arcRef As Reference,
origin As XYZ,
dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewRadialDimension(
View^ view,
Reference^ arcRef,
XYZ^ origin,
DimensionType^ dimensionType
)
member NewRadialDimension :
view : View *
arcRef : Reference *
origin : XYZ *
dimensionType : DimensionType -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
- arcRef Reference
- Geometric reference of the arc to which the dimension is to be bound.
- origin XYZ
- The point where the witness line of the radial dimension will lie.
- dimensionType DimensionType
- The dimension style to be used for the dimension.
Return Value
DimensionIf creation was successful the new arc length dimension is returned,
otherwise an exception with failure information will be thrown.
Exceptions
Remarks The dimension will be created on default place.
See Also