FamilyItemFactoryNewAngularDimension(View, Arc, Reference, Reference, DimensionType) Method |
Creates a new angular dimension object using the specified dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewAngularDimension(
View view,
Arc arc,
Reference firstRef,
Reference secondRef,
DimensionType dimensionType
)
Public Function NewAngularDimension (
view As View,
arc As Arc,
firstRef As Reference,
secondRef As Reference,
dimensionType As DimensionType
) As Dimension
public:
Dimension^ NewAngularDimension(
View^ view,
Arc^ arc,
Reference^ firstRef,
Reference^ secondRef,
DimensionType^ dimensionType
)
member NewAngularDimension :
view : View *
arc : Arc *
firstRef : Reference *
secondRef : Reference *
dimensionType : DimensionType -> Dimension
Parameters
- view View
- The view in which the dimension is to be visible.
- arc Arc
- The extension arc of the dimension.
- firstRef Reference
- The first geometric reference to which the dimension is to be bound.
The reference must be perpendicular to the extension arc.
- secondRef Reference
- The second geometric reference to which the dimension is to be bound.
The reference must be perpendicular to the extension arc.
- dimensionType DimensionType
- The dimension style to be used for the dimension.
Return Value
DimensionIf creation was successful the new angular dimension is returned,
otherwise an exception with failure information will be thrown.
Exceptions
See Also