ItemFactoryBaseNewAlignment Method |
Add a new locked alignment into the Autodesk Revit document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Dimension NewAlignment(
View view,
Reference reference1,
Reference reference2
)
Public Function NewAlignment (
view As View,
reference1 As Reference,
reference2 As Reference
) As Dimension
public:
Dimension^ NewAlignment(
View^ view,
Reference^ reference1,
Reference^ reference2
)
member NewAlignment :
view : View *
reference1 : Reference *
reference2 : Reference -> Dimension
Parameters
- view View
- The view that determines the orientation of the alignment.
- reference1 Reference
- The first reference.
- reference2 Reference
- The second reference.
Return Value
DimensionIf creation was successful the new locked alignment dimension is returned,
otherwise an exception with failure information will be thrown.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the input argument-"view" or "headerReference" or "otherReference"-is .
|
ArgumentException |
Thrown when the input argument-"headerReference" or "otherReference"-is invalid.
|
RemarksThese two references must be one of the following combinations:
- 2 planar faces
- planar face and reference plane
- 2 lines
- line and point
- line and reference plane
- 2 arcs
- 2 cylindrical faces
These references must be already geometrically aligned (this function will
not force them to become aligned).
See Also