Face Class

A bounded face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBFace
        More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Face : GeometryObject

The Face type exposes the following members.

Properties
 NameDescription
Public propertyAreaThe area of this face.
Public propertyEdgeLoopsA collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
Public propertyHasRegionsIdentifies if the face contains regions (which can be created, for example, by the Split Face command).
Public propertyIsCyclicIndicates whether the underlying surface is periodic in the specified parametric direction.
Public propertyIsTwoSidedDetermines if a face is two-sided (degenerate).
Public propertyMaterialElementIdThe element ID of the material from which this face is composed.
Public propertyOrientationMatchesSurfaceOrientation Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public propertyPeriodThe period of the underlying surface in the specified parametric direction.
Public propertyReferenceReturns a stable reference to the face.
Top
Methods
 NameDescription
Public methodComputeDerivativesReturns the first partial derivatives of the underlying surface at the specified point.
Public methodComputeNormalReturns the normal vector for the face at the given point.
Public methodComputeSecondDerivativesReturns the second partial derivatives of the face at the specified point.
Public methodEvaluateEvaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public methodGetBoundingBoxReturns the UV bounding box of the face.
Public methodGetEdgesAsCurveLoopsReturns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public methodGetRegionsGets the face regions (created, for example, by the Split Face command) of the face.
Public methodGetSurfaceReturns a copy of this face's surface.
Public methodIntersect(Curve)Calculates the intersection of the specified curve with this face.
Public methodIntersect(Face)Calculates the intersection of the specified face with this face and returns the intersection results.
Public methodIntersect(Curve, IntersectionResultArray)Calculates the intersection of the specified curve with this face and returns the intersection results.
Public methodIntersect(Face, Curve)Calculates the intersection of the specified face with this face and returns the intersection results.
Public methodIsInside(UV)Indicates whether the specified point is within this face.
Public methodIsInside(UV, IntersectionResult)Indicates whether the specified point is within this face and outputs additional information about the point location.
Public methodProjectProjects the specified point on the face.
Public methodCode exampleTriangulateReturns a triangular mesh approximation to the face.
Public methodTriangulate(Double)Returns a triangular mesh approximation to the face.
Top
Remarks
Faces are defined by surfaces (Surface) bounded by edge loops. The surfaces provide natural UV parameterization to the faces.
See Also
Inheritance Hierarchy