Face Class

A bounded face of a 3d solid or open shell.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBFace
        More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Face : GeometryObject

The Face type exposes the following members.

Properties
 NameDescription
Public propertyAreaThe area of this face.
Public propertyEdgeLoopsA collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
Public propertyCode exampleGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyHasRegionsIdentifies if the face contains regions (which can be created, for example, by the Split Face command).
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsCyclicIndicates whether the underlying surface is periodic in the specified parametric direction.
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsTwoSidedDetermines if a face is two-sided (degenerate).
Public propertyMaterialElementIdThe element ID of the material from which this face is composed.
Public propertyOrientationMatchesSurfaceOrientation Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
Public propertyPeriodThe period of the underlying surface in the specified parametric direction.
Public propertyReferenceReturns a stable reference to the face.
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodComputeDerivativesReturns the first partial derivatives of the underlying surface at the specified point.
Public methodComputeNormalReturns the normal vector for the face at the given point.
Public methodComputeSecondDerivativesReturns the second partial derivatives of the face at the specified point.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodEvaluateEvaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
Public methodGetBoundingBoxReturns the UV bounding box of the face.
Public methodGetEdgesAsCurveLoopsReturns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetRegionsGets the face regions (created, for example, by the Split Face command) of the face.
Public methodGetSurfaceReturns a copy of this face's surface.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIntersect(Curve)Calculates the intersection of the specified curve with this face.
Public methodIntersect(Face)Calculates the intersection of the specified face with this face and returns the intersection results.
Public methodIntersect(Curve, IntersectionResultArray)Calculates the intersection of the specified curve with this face and returns the intersection results.
Public methodIntersect(Face, Curve)Calculates the intersection of the specified face with this face and returns the intersection results.
Public methodIsInside(UV)Indicates whether the specified point is within this face.
Public methodIsInside(UV, IntersectionResult)Indicates whether the specified point is within this face and outputs additional information about the point location.
Public methodProjectProjects the specified point on the face.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Public methodCode exampleTriangulateReturns a triangular mesh approximation to the face.
Public methodTriangulate(Double)Returns a triangular mesh approximation to the face.
Top
Remarks
Faces are defined by surfaces (Surface) bounded by edge loops. The surfaces provide natural UV parameterization to the faces.
See Also
Inheritance Hierarchy