Projects the specified point on the face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IntersectionResult Project(
XYZ point
)
Public Function Project (
point As XYZ
) As IntersectionResult
public:
IntersectionResult^ Project(
XYZ^ point
)
member Project :
point : XYZ -> IntersectionResult
Parameters
- point XYZ
- The point to be projected.
Return Value
IntersectionResultGeometric information if projection is successful;
if projection fails or the nearest point is outside of this face, returns
.
Remarks
The following is the meaning of IntersectionResult's members:
- XYZPoint is the nearest point to the projected point on the face.
- UVPoint is the UV coordinates of the nearest point on the face.
- Distance is the distance from the point to the face.
- EdgeObject is the edge if projected point is near an edge.
- EdgeParameter is the parameter of the nearest point on the edge.
See Also