FaceIntersect(Face) Method |
Calculates the intersection of the specified face with this face and returns the intersection results.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FaceIntersectionFaceResult Intersect(
Face face
)
Public Function Intersect (
face As Face
) As FaceIntersectionFaceResult
public:
FaceIntersectionFaceResult Intersect(
Face^ face
)
member Intersect :
face : Face -> FaceIntersectionFaceResult
Parameters
- face Face
- The specified face to intersect with this face.
Return Value
FaceIntersectionFaceResult- FaceIntersectionFaceResult.Intersecting - One or more intersections were encountered.
- SetComparisonResult.NonIntersecting - There is no intersection found.
Exceptions
Remarks
This is not a general-purpose function: it only works properly for simple configurations.
For other configurations, it may return an incorrect result.
Some configurations for which the function might return a correct result are:
- A planar face that fully intersects another face in a single curve, when the other face is planar or cylindrical.
- A cylindrical face that fully intersects another face in a single curve, when the other face is planar.
See Also