Gets the face regions (created, for example, by the Split Face command) of the face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Face> GetRegions()
Public Function GetRegions As IList(Of Face)
public:
IList<Face^>^ GetRegions()
member GetRegions : unit -> IList<Face>
Return Value
IListFaceA list of faces, one for the main face of the object hosting the Split Face (such as wall or floor)
and one face for each Split Face regions.
RemarksUse the FaceSplitter class to filter and find elements which may generate face regions.
See Also