Returns the normal vector for the face at the given point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ ComputeNormal(
UV point
)
Public Function ComputeNormal (
point As UV
) As XYZ
public:
XYZ^ ComputeNormal(
UV^ point
)
member ComputeNormal :
point : UV -> XYZ
Parameters
- point UV
- The parameters to be evaluated, in natural parameterization of the face.
Return Value
XYZThe normal vector. This vector will be normalized.
Remarks
Differs from the normal returned from
ComputeDerivatives(UV) in that this vector is the "face normal" vector.
It will always be oriented to point out of a solid that contains the face.
See Also