FaceOrientationMatchesSurfaceOrientation Property |
Returns true if this face's orientation matches the orientation of the face's surface,
false if they have opposite orientations.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool OrientationMatchesSurfaceOrientation { get; }
Public ReadOnly Property OrientationMatchesSurfaceOrientation As Boolean
Get
public:
property bool OrientationMatchesSurfaceOrientation {
bool get ();
}
member OrientationMatchesSurfaceOrientation : bool with get
Property Value
Boolean
Remarks
(Revit uses only orientable faces and surfaces).
At any point on a face or surface, the face's or surface's orientation is specified by
the normal vector at that point.
The face's normal vector can be the same or opposite to that of its surface.
If OrientationMatchesSurfaceOrientation() is true, then the face’s normal vector is the same as
that of its surface at each point on the face, otherwise the normal vectors are opposite.
See also Surface::OrientationMatchesParametricOrientation.
See Also