FaceIntersect(Curve, IntersectionResultArray) Method |
Calculates the intersection of the specified curve with this face and returns the intersection results.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic SetComparisonResult Intersect(
Curve curve,
out IntersectionResultArray results
)
Public Function Intersect (
curve As Curve,
<OutAttribute> ByRef results As IntersectionResultArray
) As SetComparisonResult
public:
SetComparisonResult Intersect(
Curve^ curve,
[OutAttribute] IntersectionResultArray^% results
)
member Intersect :
curve : Curve *
results : IntersectionResultArray byref -> SetComparisonResult
Parameters
- curve Curve
- The specified curve to intersect with this face.
- results IntersectionResultArray
- Provides more information about the intersection.
Return Value
SetComparisonResult- SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
- SetComparisonResult.Subset - The curve is coincident with the surface.
- SetComparisonResult.Disjoint - There is no intersection found.
Exceptions
Remarks
The array of the intersection results contains one entry for each point where this face and the curve intersect.
The following is the meaning of IntersectionResult's members:
- XYZPoint is the evaluated intersection point.
- UVPoint is the intersection parameters on the face.
- Parameter is the raw intersection parameter on the curve.
- EdgeObject is the edge if the intersection happens to be near an edge of the face.
- EdgeParameter is the parameter of the nearest point on the edge.
See Also