FaceGetEdgesAsCurveLoops Method |
Returns a list of closed curve loops that correspond to the edge loops of the face.
Curves in each curve loop correspond to individual edges.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<CurveLoop> GetEdgesAsCurveLoops()
Public Function GetEdgesAsCurveLoops As IList(Of CurveLoop)
public:
IList<CurveLoop^>^ GetEdgesAsCurveLoops()
member GetEdgesAsCurveLoops : unit -> IList<CurveLoop>
Return Value
IListCurveLoopA list of closed curve loops, that correspond edges of face.
Remarks
Orientations of the curves and curve loops match the orientations of the face's edges and edge loops.
The order of the CurveLoops should be considered as arbitrary.
See Also