FaceComputeDerivatives Method |
Returns the first partial derivatives of the underlying surface at the specified point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Transform ComputeDerivatives(
UV point
)
Public Function ComputeDerivatives (
point As UV
) As Transform
public:
Transform^ ComputeDerivatives(
UV^ point
)
member ComputeDerivatives :
point : UV -> Transform
Parameters
- point UV
- The parameters to be evaluated, in natural parameterization of the face.
Return Value
TransformA transformation containing tangent vectors and a normal vector.
Remarks
The following is the meaning of the transformation members:
- Origin is the point on the face (equivalent to Evaluate(UV));
- BasisX is the tangent vector along the U coordinate (partial derivative with respect to U).
- BasisY is the tangent vector along the V coordinate (partial derivative with respect to V).
- BasisZ is the underlying surface's normal vector. This is not necessarily aligned with the normal vector pointing out of a
solid that contains the face, to get that value use ComputeNormal(UV).
None of the vectors are normalized.
See Also