UV Class

Object representing coordinates in 2-dimensional space.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UV

The UV type exposes the following members.

Constructors
 NameDescription
Public methodUVCreates a default UV with the values (0, 0).
Public methodUV(Double, Double)Creates a UV with the supplied coordinates.
Top
Properties
 NameDescription
Public propertyStatic memberBasisUThe basis of the U axis.
Public propertyStatic memberBasisVThe basis of the V axis.
Public propertyItem 
Public propertyUGets the first coordinate.
Public propertyVGets the second coordinate.
Public propertyStatic memberZeroThe coordinate origin or zero 2-D vector.
Top
Methods
 NameDescription
Public methodAddAdds the specified 2-D vector to this 2-D vector and returns the result.
Public methodAngleToReturns the angle between this vector and the specified vector.
Public methodCrossProductThe cross product of this 2-D vector and the specified 2-D vector.
Public methodDistanceToReturns the distance from this 2-D point to the specified 2-D point.
Public methodDivideDivides this 2-D vector by the specified value and returns the result.
Public methodDotProductThe dot product of this 2-D vector and the specified 2-D vector.
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLengthThe length of this 2-D vector.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsAlmostEqualTo(UV)Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public methodIsAlmostEqualTo(UV, Double)Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public methodIsUnitLengthThe boolean value indicates whether this 2-D vector is of unit length.
Public methodIsZeroLengthThe boolean value indicates whether this 2-D vector is a zero vector.
Public methodMultiplyMultiplies this 2-D vector by the specified value and returns the result.
Public methodNegateNegates this 2-D vector.
Public methodNormalizeReturns a new UV whose coordinates are the normalized values from this vector.
Public methodSubtractSubtracts the specified 2-D vector from this 2-D vector and returns the result.
Public methodToString Gets formatted string showing (U, V) with values formatted to 9 decimal places.
(Overrides ObjectToString)
Top
Operators
 NameDescription
Public operatorStatic memberAddition(UV, UV)Adds the two specified 2-D vectors and returns the result.
Public operatorStatic memberDivision(UV, Double)Divides the specified 2-D vector by the specified value.
Public operatorStatic memberMultiply(Double, UV)The product of the specified number and the specified 2-D vector.
Public operatorStatic memberMultiply(UV, Double)The product of the specified number and the specified 2-D vector.
Public operatorStatic memberSubtraction(UV, UV)Subtracts the two specified 2-D vectors and returns the result.
Public operatorStatic memberUnaryNegation(UV)Negates this 2-D vector and returns the result.
Top
Remarks
Usually this means parameters on a surface. In actual use, it could be interpreted as either point or vector in 2-dimensional space.
See Also