FormatOptions(ForgeTypeId) Constructor |
Creates a new FormatOptions object that represents custom formatting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FormatOptions(
ForgeTypeId unitTypeId
)
Public Sub New (
unitTypeId As ForgeTypeId
)
public:
FormatOptions(
ForgeTypeId^ unitTypeId
)
new :
unitTypeId : ForgeTypeId -> FormatOptions
Parameters
- unitTypeId ForgeTypeId
-
Identifier of the unit to display.
ExceptionsException | Condition |
---|
ArgumentException |
unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
|
ArgumentNullException |
A non-optional argument was null
|
See Also