FormatOptionsIsValidSymbol(ForgeTypeId, ForgeTypeId) Method |
Checks whether a symbol is valid for a given unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidSymbol(
ForgeTypeId unitTypeId,
ForgeTypeId symbolTypeId
)
Public Shared Function IsValidSymbol (
unitTypeId As ForgeTypeId,
symbolTypeId As ForgeTypeId
) As Boolean
public:
static bool IsValidSymbol(
ForgeTypeId^ unitTypeId,
ForgeTypeId^ symbolTypeId
)
static member IsValidSymbol :
unitTypeId : ForgeTypeId *
symbolTypeId : ForgeTypeId -> bool
Parameters
- unitTypeId ForgeTypeId
-
Identifier of the unit.
- symbolTypeId ForgeTypeId
-
Identifier of the symbol to check.
Return Value
Boolean
True if the symbol is valid, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
|
ArgumentNullException |
A non-optional argument was null
|
See Also