FormatOptionsIsValidAccuracy(ForgeTypeId, Double) Method |
Checks whether an accuracy is valid for a given unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidAccuracy(
ForgeTypeId unitTypeId,
double accuracy
)
Public Shared Function IsValidAccuracy (
unitTypeId As ForgeTypeId,
accuracy As Double
) As Boolean
public:
static bool IsValidAccuracy(
ForgeTypeId^ unitTypeId,
double accuracy
)
static member IsValidAccuracy :
unitTypeId : ForgeTypeId *
accuracy : float -> bool
Parameters
- unitTypeId ForgeTypeId
-
Identifier of the unit.
- accuracy Double
-
The accuracy to check.
Return Value
Boolean
True if the accuracy is valid, false otherwise.
ExceptionsException | Condition |
---|
ArgumentException |
unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
|
ArgumentNullException |
A non-optional argument was null
|
Remarks
See the
Accuracy property for details on
valid accuracy values.
See Also