FormatOptionsSetUnitTypeId Method

Sets the unit used to quantify values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FormatOptions SetUnitTypeId(
	ForgeTypeId unitTypeId
)

Parameters

unitTypeId  ForgeTypeId
The unit identifier.

Return Value

FormatOptions
Exceptions
ExceptionCondition
ArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException A non-optional argument was null
InvalidOperationException UseDefault is true in this FormatOptions.
See Also