Autodesk.Revit.DB.IFC Namespace

 
Classes
 ClassDescription
Public classExporterIFC The main class provided by Revit to allow implementation of IFC export.
Public classExporterIFCUtils A class that contains utilities needed to implement Revit's version of the IFC export client application.
Public classHostObjectSubcomponentInfo A class that contains roof or floor slab information, calculated by ExporterIFCUtils.ComputeSubcomponents().
Public classIFCAggregate A collection of IFC handles or attributes.
Public classIFCAggregateIterator A class used to iterate individual objects in an IFCAggregate.
Public classIFCAnyHandle A handle representing an item in an IFC file.
Public classIFCConnectedWallData A class that contains the IFC-specific information about how an element is joined to another element.
Public classIFCData A specialized type of abstract data block that can represent any data type.
Public classIFCExtrusionCalculatorOptions This class contains the options used to calculate extrusions from Revit geometry.
Public classIFCExtrusionCalculatorUtils A utility class used to calculate extrusion data from Revit geometry for IFC export.
Public classIFCExtrusionCreationData A utility object that is used to pass information related to extrusion creation.
Public classIFCExtrusionData Represents the geometry of an extrusion (a solid body or opening) generated from Revit geometry.
Public classIFCFamilyInstanceExtrusionExportResults This class represents the results of a geometric analysis of a family instance.
Public classIFCFile Represents the IFC file which is being created during export.
Public classIFCFileModelOptions This class contains options to create an IFC file model.
Public classIFCFileReadOptions This class contains options to read an IFC file.
Public classIFCFileWriteOptions This class contains options to write an IFC file.
Public classIFCGeometryInfo A container class for Revit geometry extracted from an element.
Public classIFCGuidKey IFCGuidKey is used for case-sensitive comparison of GUID values for maps and sets.
Public classIFCHybridImport Driver for Performing Hybrid Imports.
Public classIFCImportOptions IFC Import options.
Public classIFCLegacyStairOrRamp The class contains the components of a legacy stair or ramp.
Public classIFCLevelInfo Represents information about a particular level in the document.
Public classIFCLinkDocumentExportScope A class that allows for the export of one linked document to IFC.
Public classIFCOpeningData A class that contains opening data including extrusion data, opening solids and opening element id.
Public classIFCProductWrapper This class is used to ensure that elements and objects are associated with the current IfcProduct.
Public classIFCRange Typically for IFC export, this represents the lower and upper elevations for split wall and column geometry.
Public classIFCTransaction IFC transactions are context-like objects that guard any changes made to an IFC file.
Public classIFCTransformSetter A state-based class that forces an extra transformation applied to objects being exported.
Public classImporterIFC The main class provided by Revit to allow implementation of IFC import.
Public classImporterIFCUtils A class that contains utilities needed to implement Revit's version of the IFC import client application.
Public classRoofComponents A class that contains multiple roof slab infos of a roof.
Interfaces
 InterfaceDescription
Public interfaceIExporterIFC The interface used to implement a custom IFC exporter.
Public interfaceIIFCImporterServer Interface for external servers implementing IFC import.
Enumerations
 EnumerationDescription
Public enumerationIFCConnectedWallDataLocation An enumerated type that represents the location where an element is connected to a wall.
Public enumerationIFCDataPrimitiveType Used in operations to specify the primitive type of an IFCData.
Public enumerationIFCExtrusionAxes Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.
Public enumerationIFCExtrusionBasis This enumerated type represents the possible bases for derivation of extrusion geometry.
Public enumerationIFCFileFormat The IFC file format.
Public enumerationIFCImportAction The action of the IFC import.
Public enumerationIFCImportIntent The intent of the IFC import.
Public enumerationIFCLogical A datatype can have values TRUE, FALSE, UNKNOWN or UNSET.
Public enumerationIFCProjectLevelGUIDType The type of the GUID to be retrieved from Revit.