IFCDataPrimitiveType Enumeration |
Used in operations to specify the primitive type of an IFCData.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum IFCDataPrimitiveType
Public Enumeration IFCDataPrimitiveType
public enum class IFCDataPrimitiveType
type IFCDataPrimitiveType
MembersMember name | Value | Description |
---|
Integer | 0 |
Integer.
|
Double | 1 |
Double.
|
Boolean | 2 |
Boolean.
|
Logical | 3 |
IFCLogical type.
|
String | 4 |
String.
|
Binary | 5 |
Binary.
When reading or writing an IFCData of primitive type Binary,
the value will be the string representation of the binary value
as seen in the IFC specification.
|
Enumeration | 6 |
Enumeration.
When reading or writing an IFCData of primitive type Enumeration,
the value will be the string representation of the enumeration value
as seen in the IFC specification.
|
Instance | 7 |
Represents IFCAnyHandle.
|
Aggregate | 8 |
Represents IFCAggregate.
|
Unknown | 9 |
Unknown.
|
Number | 10 |
Number.
|
See Also