IFCHybridImport Class

Driver for Performing Hybrid Imports.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCHybridImport

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCHybridImport : IDisposable

The IFCHybridImport type exposes the following members.

Constructors
 NameDescription
Public methodIFCHybridImport Constructs a new IFCHybridImport instance for importing IFC via Hybrid method.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodCreateMap 
Public methodDisposeReleases all resources used by the IFCHybridImport
Public methodGetIFCStepIdToElementIdMap Retrieves the association between the original IFC STEP identifiers and the created or updated Elements.
Public methodImportElements Imports IFC Elements using AnyCAD.
Public methodUpdateElements Updates IFC Elements using AnyCAD.
Top
See Also