IFCGuidKey Class

IFCGuidKey is used for case-sensitive comparison of GUID values for maps and sets.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCGuidKey

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCGuidKey : IDisposable

The IFCGuidKey type exposes the following members.

Constructors
 NameDescription
Public methodIFCGuidKey(IFCGuidKey) IFCGuidKey can be used in managed code as well as unmanaged.
Public methodIFCGuidKey(String) Constructs a new IFCHybridGuid
Top
Properties
 NameDescription
Public propertyIFCGlobalId IFC GlobalId for map.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the IFCGuidKey
Public methodEquals Determines whether this IFCGuidKey is equal to another.
(Overrides ObjectEquals(Object))
Public methodGetHashCode Returns the hash code for this IFCGuidKey
(Overrides ObjectGetHashCode)
Top
See Also