HostObjectSubcomponentInfo Class

A class that contains roof or floor slab information, calculated by ExporterIFCUtils.ComputeSubcomponents().
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCHostObjectSubcomponentInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class HostObjectSubcomponentInfo : IDisposable

The HostObjectSubcomponentInfo type exposes the following members.

Properties
 NameDescription
Public propertyAreaOfCurveLoop The area of the CurveLoop of the roof or floor slab.
Public propertyDepth The depth of the roof or floor slab.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyLoopFace The face of the loops of the roof or floor slab.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the HostObjectSubcomponentInfo
Public methodGetCurveLoop Gets the CurveLoop representing the base profile curve loop of the roof or floor slab
Public methodGetPlane Gets the plane representing the normal and origin of the surface containg the base profile curve loop of the roof or floor slab.
Top
Remarks
A slab is an extrusion with one outer and no inner base profile curve loops, created by extruding the base profile loop in the direction Plane.Normal a distance given by the Depth value.
See Also