IFCRange Class

Typically for IFC export, this represents the lower and upper elevations for split wall and column geometry.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCRange

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCRange : IDisposable

The IFCRange type exposes the following members.

Constructors
 NameDescription
Public methodIFCRange Instantiates a default IFCRange object.
Public methodIFCRange(IFCRange) Instantiates an IFCRange object by copy.
Public methodIFCRange(Double, Double) Instantiates an IFCRange object.
Top
Properties
 NameDescription
Public propertyEnd The ending value of the range.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyStart The starting value of the range.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the IFCRange
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
It contains two double values representing the starting and ending values as a range.
See Also