IFCLevelInfo Class

Represents information about a particular level in the document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCLevelInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCLevelInfo : IDisposable

The IFCLevelInfo type exposes the following members.

Properties
 NameDescription
Public propertyDistanceToNextLevel The distance to the next story level.
Public propertyElevation The elevation of the level.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates an IFCLevelInfo.
Public methodDisposeReleases all resources used by the IFCLevelInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBuildingStorey Gets the IfcBuildingStorey handle.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLocalPlacement Gets the local placement.
Public methodGetRelatedElements Gets all building elements on this level.
Public methodGetRelatedProducts Gets all building products on this level.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Level information includes the height, which is the distance to from this level to the next available level, and the actual elevation of the level, in the Revit default units.
See Also