IFCLinkDocumentExportScope Class

A class that allows for the export of one linked document to IFC.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCLinkDocumentExportScope

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCLinkDocumentExportScope : IDisposable

The IFCLinkDocumentExportScope type exposes the following members.

Constructors
 NameDescription
Public methodIFCLinkDocumentExportScope Instantiates a default IFCLinkDocumentExportScope object.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the IFCLinkDocumentExportScope
Top
Remarks
Linked documents can only be exported within a transaction, but it is illegal to start a transaction for a linked document. This gives a special exception that does the work necessary to make sure that the host documents do not end up in unstable states after the export. This is not guaranteed for any other workflow. To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.
See Also