IFCTransaction Class

IFC transactions are context-like objects that guard any changes made to an IFC file.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCTransaction

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCTransaction : IDisposable

The IFCTransaction type exposes the following members.

Constructors
 NameDescription
Public methodIFCTransaction Instantiates a transaction object.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodCommit Commits all changes made to the IFC file during the transaction.
Public methodDisposeReleases all resources used by the IFCTransaction
Public methodRollBack Rolls back all changes made to the IFC file during the transaction.
Top
Remarks
Any change to an IFC file can only be made while there is an active transaction open for that file. Changes do not become a part of the file until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly (by the destructor).
See Also