IFCAggregate Class

A collection of IFC handles or attributes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCAggregate

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCAggregate : IEnumerable<IFCData>, 
	IDisposable

The IFCAggregate type exposes the following members.

Properties
 NameDescription
Public propertyCount The number of the data values in the aggregate.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyItem Get the IFCData for this aggregate.
Top
Methods
 NameDescription
Public methodAdd Adds an element to the aggregate.
Public methodAddAggregate Creates a nested aggregate and adds it to the aggregate.
Public methodAddValueOfType Adds an ifc object with primitive type of aggregate's item type to the aggregate.
Public methodDelete Delete the aggregate object from the IFCFile model.
Public methodDisposeReleases all resources used by the IFCAggregate
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Protected methodGetBasicIEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetEnumeratorReturns an enumerator that iterates through a collection.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetIFCAggregateIterator Returns a IFCAggregateIterator that iterates through the collection.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also