IFCImportOptions Class

IFC Import options.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCImportOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCImportOptions : IDisposable

The IFCImportOptions type exposes the following members.

Constructors
 NameDescription
Public methodIFCImportOptions Constructs a new IFCImportOptions using default settings.
Top
Properties
 NameDescription
Public propertyAction The action of the import.
Public propertyAutocorrectOffAxisLines Enable or disable correcting lines that are slight off-axis.
Public propertyAutoJoin Enable or disable auto-join at the end of import.
Public propertyCreateLinkInstanceOnly Determines whether to create a linked symbol element or not.
Public propertyForceImport Force the IFC file to be imported regardless of an existing corresponding Revit file.
Public propertyIntent The intent of the import.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyRevitLinkFileName The full path of the intermediate Revit file created during a previous link action. This is used during "Reload From" to determine the path to the previous generated Revit file.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the IFCImportOptions
Public methodGetConversionData Get the data used in the creation of the associated Revit file for an IFC link operation, if it exists.
Public methodGetExtraOptions Get the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value.
Public methodSetExtraOptions Set the list of extra options to be passed into the importer. Each entry in the map is a pair of option name and value. Note that any value here will overwrite the other values in the IFCImportOptions, if it has the same name.
Top
See Also