IFCExtrusionData Class

Represents the geometry of an extrusion (a solid body or opening) generated from Revit geometry.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCExtrusionData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCExtrusionData : IDisposable

The IFCExtrusionData type exposes the following members.

Constructors
 NameDescription
Public methodIFCExtrusionData Constructs a new empty extrusion data object.
Top
Properties
 NameDescription
Public propertyExtrusionBasis The basis used for the extrusion.
Public propertyExtrusionDirection The direction used for the extrusion.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyScaledExtrusionLength The length of the extrusion, scaled in the units of the export.
Top
Methods
 NameDescription
Public methodAddLoop Adds a curve loop to the extrusion data.
Public methodClearLoops Clears the curve loops stored in the extrusion data.
Public methodDisposeReleases all resources used by the IFCExtrusionData
Public methodGetLoops Gets the curve loops that form the base shape of the extrusion.
Public methodIsValid Determines if the extrusion data represents a valid extrusion.
Public methodRemoveLoopAt Removes the loop at the specified index.
Top
See Also