IFCProductWrapper Class

This class is used to ensure that elements and objects are associated with the current IfcProduct.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCProductWrapper

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCProductWrapper : IDisposable

The IFCProductWrapper type exposes the following members.

Properties
 NameDescription
Public propertyCount The number of objects associated with the IfcProduct in this wrapper.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodAddAnnotation Adds an annotation handle to associate with the IfcProduct in this wrapper.
Public methodAddBuilding Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.
Public methodAddElement Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public methodAddFinishMaterial Adds a material handle to associate with the IfcProduct in this wrapper.
Public methodAddSite Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.
Public methodAddSpace Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Public methodClearFinishMaterials Clear finish materials in this wrapper.
Public methodStatic memberCreate(IFCProductWrapper) Establishes a new product manager for elements and objects derived from a parent product manager.
Public methodStatic memberCreate(ExporterIFC, Boolean) Establishes a new baseline product manager for elements and objects.
Public methodStatic memberCreate(IFCProductWrapper, Boolean) Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel
Public methodDisposeReleases all resources used by the IFCProductWrapper
Public methodFindExtrusionCreationParameters Obtains the extrusion creation data associated with the given element.
Public methodGetAllObjects Gets all objects associated with the IfcProduct in this wrapper.
Public methodGetAnElement Gets the first element handle added to this wrapper.
Top
Remarks
Each instance makes sure that any elements and products created during its lifetime are properly associated to their parent level (or other containing object). To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.
See Also