IFCFile Class

Represents the IFC file which is being created during export.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCFile

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCFile : IDisposable

The IFCFile type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodClose Close the IFC file.
Public methodStatic memberCreate Creates an IFC file for exporting.
Public methodCreateHeaderInstance Creates an IFC header instance in the file model.
Public methodCreateInstance Creates an IFC instance in the file model.
Public methodCreateStyle(ExporterIFC, IFCAnyHandle) Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public methodCreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public methodDisposeReleases all resources used by the IFCFile
Public methodGetInstanceCount Counts IFC instances of one particular type.
Public methodGetInstances Gets IFC instances of one particular type.
Public methodRead(IFCFileReadOptions) Reads content from a file of IFC format.
Public methodRead(IFCFileReadOptions, Int32, Int32) Reads content from a file of IFC format.
Public methodWrite Writes content to a file of IFC format.
Top
See Also