IFCLegacyStairOrRamp Class

The class contains the components of a legacy stair or ramp.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCLegacyStairOrRamp

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCLegacyStairOrRamp : IDisposable

The IFCLegacyStairOrRamp type exposes the following members.

Properties
 NameDescription
Public propertyIsRamp True if it is a ramp, false if it is a stair.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyRiserHeight The height of riser.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the IFCLegacyStairOrRamp
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundaryLines Gets boundary lines.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLandingGeometries Gets the geometries of landings.
Public methodGetNumberOfRisers Gets the number of risers.
Public methodGetNumberOfTreads Gets the number of treads.
Public methodGetRunGeometries Gets the geometries of runs.
Public methodGetStringerGeometries Gets the geometries of stringers.
Public methodGetTreadsLength Gets the length of treads.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetWalkLines Gets walk lines.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also