IFCAggregateIterator Class

A class used to iterate individual objects in an IFCAggregate.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCIFCAggregateIterator

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCAggregateIterator : IEnumerator<IFCData>

The IFCAggregateIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the IFCAggregateIterator
Public methodMoveNext Increments the iterator to the next object in the IFCAggregate.
Public methodReset Resets the iterator to the beginning of the aggregate.
Top
See Also