ImporterIFC Class

The main class provided by Revit to allow implementation of IFC import.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCImporterIFC

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ImporterIFC : IDisposable

The ImporterIFC type exposes the following members.

Properties
 NameDescription
Public propertyDocument Gets the document associated with the import.
Public propertyFullFileName The full file name of the IFC file to be import.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ImporterIFC
Public methodGetOptions Gets the collection of named options set by the importer client.
Public methodHybridCreateImportMapObsolete.
Public methodHybridElementImportObsolete.
Imports IFC Elements using non-open-source framework.
Public methodProcessIFCProject(IFCAnyHandle) The entry point to the native IFC import function. Processes the main IfcProject and creates appropriate Revit elements.
Public methodProcessIFCProject(IFCAnyHandle, IDictionaryIFCAnyHandle, ElementId) 
Public methodSetFile Sets the handle to the IFC file being created during this import operation.
Top
Remarks
An instance of this class is provided to clients which implement IImporterIFC in order to provide an implementation for IFC import. It contains information on the options selected by the user for the import operation, as well as members used to access specific types of data needed to implement the import properly.
See Also