ImporterIFCUtils Class

A class that contains utilities needed to implement Revit's version of the IFC import client application.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.IFCImporterIFCUtils

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ImporterIFCUtils

The ImporterIFCUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberCreateEmptyFamily Creates an empty family of a given category.
Public methodStatic memberGetLocalFileName Get the local file name, including the path, corresponding to a linked IFC file. This will create a local copy of the IFC file if necessary.
Public methodStatic memberUpdateDirectShapeCategory Updates the category of a DirectShape.
Top
Remarks
This class contains special API utilities needed to enable the implementation of the client application for IFC import. Some of these utilities will be needed temporarily while the code for IFC import is migrated into the export client. These temporary interfaces are likely to change in upcoming Revit releases.
See Also